The Burton Tech Journal

Simulate a Windows Application Deployment Lifecycle

by on Sep.21, 2008, under Microsoft Windows XP, Windows Application Deployment, Windows Vista

If a domain test bed is not avaiable, either real or virtualized, it is best to use a single workstation to test an unproven MSI based package. Frequently the deployment process is hung up when the MSI performs a custom action that requires some form of user interaction. It is important to not only look for this behavior in new installations, but also MSI’s used to upgrade long functioning deployed applications, before introducing either to your GPO.

This is the recommended test procedure:

A) Perform an installation and look for dialogues that require user intervention:

  1. MSIEXEC /i “\\path_to_msi” /qb
  2. The /i switch tells MSIEXEC to install or configure a product
  3. The /qb switch tells MSIEXEC to use a basic UI

B) If the application does not install correctly, check the MSI log file for errors. Otherwise confirm the application is functioning correctly.

C) It is critical to test what happens during uninstallation of the application too. Any user interaction requirements could cause a failure when upgrading or removing your application later. Run the following command to observe the uninstall process:

  1. MSIEXEC /x “\\path_to_msi” /qb
  2. The /x switch tells MSIEXEC to uninstall the product

D) If the application installs and uninstalls without requiring user interaction, it will probably work fine deployed. To finalize a simulation, the application should be silently installed remotely using PSEXEC and the following commands:

  1. PSEXEC -u context\username -p password \\target_machine MSIEXEC.EXE /i “\\path_to_msi” /qn

E) Confirm the application functions correctly with an unprivileged user account. Check the MSI log on the target machine for errors if necessary.

F) Once again, test the uninstall process:

  1. PSEXEC -u context\username -p password \\target_machine MSIEXEC.EXE /x “\\path_to_msi” /qn

G) If the application appears to be working, you can proceed with assigning it to your GPO.

H) If application does not deploy, try the following:

  1. Examine the MSI logs on the client computer and make any adjustments necessary.
  2. Confirm Vista’s UAC is not blocking installation.
  3. Check http://www.appdeploy.com for valuable tips and tricks, particularly if you are deploying a popular commerical package. The site has some great resources on how to customize packages so they will install correctly.
:, , , , , , , , , , , , , , , ,

Leave a Reply

Looking for something?

Use the form below to search the site:

Still not finding what you're looking for? Drop a comment on a post or contact us so we can take care of it!

Blogroll

A few highly recommended websites...